























































		<!DOCTYPE html>







	
	




















		














	
	
		
	
	
	
	
	
	
	
		
		
	
	
		
	
	
	
	
	

	
	
	

						
	
	

	
	
	
	
	













	
	





















<!DOCTYPE html>
<html ng-app="topicsApp" class='no-js ltr' dir='ltr' lang="en-US">












    


<head>
<meta charset="utf-8">
<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=no">

            
        <title>Charges against former pastor dropped</title>
    

























































<meta content="text/html; charset=UTF-8" http-equiv="content-type" />









































































	
	

	
	
		
		
		
		
			
		
	



	
	
		<meta name="description" content="Domestic violence&amp;nbsp;charges against&amp;nbsp;former Presbyterian pastor have been dropped." lang="en-US" />
	



	
	
		<meta name="keywords" content="News,Top Stories" lang="en-US" />
	






<script>var _head_start = new Date();</script>

	<meta property="og:title" content="Charges against former pastor dropped"/><meta property="og:description" content="Domestic violence&nbsp;charges against&nbsp;former Presbyterian pastor have been dropped. "/><meta property="og:type" content="article"/><meta property="og:url" content="https://www.news4jax.com/news/florida/clay-county/former-pastor-charged-with-domestic-battery"/><meta property="og:image"  content="https://media.news4jax.com/photo/2017/10/30/James-Weldon_1509386565996_10883216_ver1.0_1280_720.jpg"/><meta property="og:image:width"  content="1280"/><meta property="og:image:height"  content="720"/><meta property="og:locale"  content="en_US"/><meta property="og:site_name"  content="WJXT"/><meta property="fb:app_id"  content="196517170397638"/><meta property="article:section"  content="Clay County"/><meta property="article:tag"  content="clay county, church, pastor, battery, domestic, fleming island, presbyterian, weldon"/><meta property="article:published_time"  content="2018-03-05T20:47:16+0000"/><meta property="article:modified_time"  content="2018-03-05T20:47:16+0000"/><meta property="article:expiration_time"  content="2042-06-21T18:01:00+0000"/>

	
	<!-- used for Google CSE --> <!-- <PageMap><DataObject type="Date"><Attribute name="sdateformat" value="20180305 20:47:16"/><Attribute name="edate" value="1520282836588"/><Attribute name="edateformat" value="20180305 20:47:16"/><Attribute name="sdate" value="1520282836697"/></DataObject><DataObject type="Site"><Attribute name="siteId" value="800004"/></DataObject><DataObject type="PageAttr"><Attribute name="Category" value="Clay County"/></DataObject><DataObject type="Story"><Attribute name="Description" value="Domestic violence&nbsp;charges against&nbsp;former Presbyterian pastor have been dropped. "/><Attribute name="Headline" value="Charges against former pastor dropped"/><Attribute name="Keywords" value="News,Top Stories"/><Attribute name="Migrated" value="false"/><Attribute name="ModDate" value="20180305 20:47:16"/><Attribute name="PubDate" value="20180305 20:47:16"/><Attribute name="type" value="story"/></DataObject><DataObject type="Thumbnail"><Attribute name="Name" value="10883216"/><Attribute name="Caption" value="<p>James Welson, 55, booking photo</p>"/><Attribute name="Credit" value="None"/><Attribute name="CompID" value="604768649"/><Attribute name="URL" value="https://media.news4jax.com/photo/2017/10/30/James-Weldon_1509386565996_10883216_ver1.0_160_90.jpg"/><Attribute name="Title" value="James+Weldon"/><Attribute name="Migrated" value="false"/></DataObject><DataObject type="Restrictions"><Attribute name="Status" value="Free"/></DataObject></PageMap> -->




    
    


















    <!-- social sharing tools -->
    <link href="https&#x3a;&#x2f;&#x2f;www&#x2e;news4jax&#x2e;com&#x2f;news&#x2f;florida&#x2f;clay-county&#x2f;former-pastor-charged-with-domestic-battery" rel="canonical"/>

	

	

		

	





	<link href="&#x2f;html&#x2f;css&#x2f;public&#x2e;css&#x3f;themeId&#x3d;gmgbasetheme_WAR_gmgbasetheme&#x26;minifierType&#x3d;css&#x26;languageId&#x3d;en_US&#x26;b&#x3d;6110&#x26;t&#x3d;1520163274000" rel="stylesheet" type="text/css" />










	

				<link href="/html/portlet/journal_content/css/main.css?themeId=gmgbasetheme_WAR_gmgbasetheme&amp;minifierType=css&amp;languageId=en_US&amp;b=6110&amp;t=1520163141000" rel="stylesheet" type="text/css" />

	

				<link href="/html/portlet/asset_publisher/css/main.css?themeId=gmgbasetheme_WAR_gmgbasetheme&amp;minifierType=css&amp;languageId=en_US&amp;b=6110&amp;t=1520163141000" rel="stylesheet" type="text/css" />

	













<script type="text/javascript">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</script>


	
		
			
			
				
					
						<script src="/html/js/barebone.jsp?themeId=gmgbasetheme_WAR_gmgbasetheme&amp;colorSchemeId=03&amp;minifierType=js&amp;minifierBundleId=javascript.barebone.files&amp;languageId=en_US&amp;b=6110&amp;t=1&amp;epversion=100" type="text/javascript"></script>
					
					
				
			
		
	
	




<script type="text/javascript">
	// <![CDATA[
		

			

			
				Liferay.Portlet.list = ['56_INSTANCE_o405cU7HgIYK','56_INSTANCE_uXk2iOoNCjCq','56_INSTANCE_C9gB4mPXoc3N','101','56_INSTANCE_WK3du8AxnQ6L','56_INSTANCE_Bg3cc3ddhDII','56_INSTANCE_dX3zuuXxTUU8','56_INSTANCE_GC1Hotk0Chyr','56_INSTANCE_hdUeW5qGcq0p','56_INSTANCE_aETvx2rzZMgz','56_INSTANCE_E91yuFABv3sh','56_INSTANCE_cE8pD6YshYD1','56_INSTANCE_PBELU96Vgkah','56_INSTANCE_DEH96AJdUkfL','56_INSTANCE_0V4LwGcTblj2','56_INSTANCE_tndpwT4WljH1','56_INSTANCE_cQqGVw90EyVU'];
			
		

		

		
	// ]]>
</script>






















<!-- GMG UI-Hook Override -->
	<script type="text/javascript">
		if( !window.EP ){ var EP = {}; }
		EP.CONST = {
			versionStr: "?epversion=100",
			useTempData: false
		};
		
		//Extend Liferay's global JS ThemeDisplay object to include methods in the JSP one
		(function(A){
			A.mix(Liferay.ThemeDisplay, {
				
				getScopeGroupName: function(){
					return 'WJXT';
				},
				getParentGroupName: function(){
					return 'WJXT';
				},
				isControlPanel: function(){
					return false;
				}
				
			});
		})(AUI());
	</script>



	


	
	
		
			<!-- JQUERY / JQUERY MIGRATE / MODERNIZR / KNOCKOUT / PUBLIC.js / EP-CAROUSEL -->
			<script src="/html/js/endplay/site-public.js?epversion=100" type="text/javascript"></script>
		
		
		
	
	




	






	
		
	
	


	



<script type="text/javascript">
	var viewStoryUrl = "/group/wjxt/create-story?type=story&storyId=";
	var viewNonstoryUrl = "/web/wjxt-staging/-/";
	var viewGalleryUrl = "/group/wjxt/create-gallery?type=gallery&storyId=";
	
	var companyId = themeDisplay.getCompanyId();
	var groupId = 32146;
	
</script>





<script type="text/javascript">
	Liferay.ThemeDisplay.getVocabularyIds = function() {
		return "32153";
	};
	Liferay.ThemeDisplay.getVocabularyGroupIds = function() {
		return "32146";
	};
</script>







	














    <link class="lfr-css-file" href="https&#x3a;&#x2f;&#x2f;www&#x2e;news4jax&#x2e;com&#x2f;gmg-base-theme&#x2f;css&#x2f;main&#x2e;css&#x3f;themeId&#x3d;gmgbasetheme_WAR_gmgbasetheme&#x26;minifierType&#x3d;css&#x26;languageId&#x3d;en_US&#x26;b&#x3d;6110&#x26;t&#x3d;1520163216000" rel="stylesheet" type="text/css" />







<style type="text/css">
	/* <![CDATA[ */
		
	/* ]]> */
</style>








	<style type="text/css">

		

			

		

			

		

			

		

			

		

			

		

			

		

			

		

			

		

			

		

			

		

			

		

			

		

			

		

			

		

			

		

			

		

			

		

	</style>




    
<!-- CSS -->
<link href='https://fonts.googleapis.com/css?family=Lato:400,100,300,700,900,100italic,300italic,400italic,700italic,900italic' rel='stylesheet' type='text/css'>

<link rel="shortcut icon" href="https://www.news4jax.com/gmg-base-theme/images/color_schemes/jac/favicon.ico">
<link rel="apple-touch-icon" href="https://www.news4jax.com/gmg-base-theme/images/color_schemes/jac/apple-touch-icon.png">

    		





												<script>
    (function(A, $){
        window.GMG = window.GMG || {};
        GMG.Util = GMG.Util || {};
    })(AUI(), jQuery);
</script>
<script>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</script>

<!-- Begin meta tags -->
        






        














































      









































































  

        <!-- Core Meta and Head Tags: Begin -->
    <meta property="og:type" content="news">
    <!--Custom meta tags begin-->
                <!--Custom meta tags end-->
		  <meta name="page-category" content="Clay County">
	                      <meta name="endplay.categories" content="Clay County">
        
      
            
                                          
            
                                                            
                        
            <meta name="article:author" content="https://www.news4jax.com/author/news4jax.comstaff">

                          <link rel="author" href="https://www.news4jax.com/author/news4jax.comstaff" title="News4Jax.com Staff">
            
            <meta name="sailthru.author" content="News4Jax.com Staff">

                    <meta name="author" itemprop="author" content="News4Jax.com Staff">

                    <meta name="content_id" itemprop="identifier" content="604768627">
      <link rel="amphtml" href="https://amp.news4jax.com/news/florida/clay-county/former-pastor-charged-with-domestic-battery" />
    
                
            
      <meta name="page-type" itemprop="pageType" content="article">
      <meta name="news_keywords" content="News">
        <!-- Core Meta and Head Tags: End -->
                <script>
	var STATUS = '630947517002223617';

	$(document).ready(function() {
	
		window.twttr = (function(d, s, id) {
			var js, fjs = d.getElementsByTagName(s)[0],
			t = window.twttr || {};
			if (d.getElementById(id)) return t;
			js = d.createElement(s);
			js.id = id;
			js.async = false;
			js.src = "https://platform.twitter.com/widgets.js";
			fjs.parentNode.insertBefore(js, fjs);

			t._e = [];
			t.ready = function(f) {
				t._e.push(f);
			};

			return t;
		}(document, "script", "twitter-wjs"));

		var showTwitterCard = function() {
			if((typeof twttr.widgets != 'undefined')) {
				twttr.widgets.load();
				twttr.widgets.createTweet(
					STATUS,
					document.getElementById('twitter-widgets-container'),
					{
					  theme: 'light'
					}
				);
			}
		};
		window.setTimeout(showTwitterCard,5000);
	});
</script>
        
        
    
                  
      <!-- Twitter OG Tags: Begin -->

      <meta property="twitter:card" content="summary">
      <meta property="twitter:title" content="Domestic battery charges against former pastor dropped">
      <meta property="twitter:site" content="@wjxt4">
      <meta property="twitter:description" content="Domestic violence&nbsp;charges against&nbsp;former Presbyterian pastor have been dropped.">
      <meta property="twitter:url" content="https://www.news4jax.com/news/florida/clay-county/former-pastor-charged-with-domestic-battery">
      <meta property="twitter:image" content="https://media.news4jax.com/photo/2017/10/30/James-Weldon_1509386565996_10883216_ver1.0_1280_720.jpg">
      <meta property="twitter:image:width" content="1280">
      <meta property="twitter:image:height" content="720">

      <!-- Twitter OG Tags: End -->
          
    <!-- Sailthru OG Tags: Begin -->
                    
        
    
          
        
    <meta name="sailthru.title" content="Domestic battery charges against former pastor dropped">
    <meta name="sailthru.description" content="Domestic violence&nbsp;charges against&nbsp;former Presbyterian pastor have been dropped.">
    <meta name="sailthru.tags" content="News,Top Stories">
    <meta name="sailthru.date" content="2018-03-05T20:47:16+0000">
    <meta name="sailthru.image.full" content="https://media.news4jax.com/photo/2017/10/30/James-Weldon_1509386565996_10883216_ver1.0_1280_720.jpg">
    <meta name="sailthru.image.thumb" content="https://media.news4jax.com/photo/2017/10/30/James-Weldon_1509386565996_10883216_ver1.0_160_90.jpg">
    <!-- Sailthru OG Tags: End -->
          
<!-- End meta tags -->

<!-- Begin header scripts -->
        <script type="text/javascript" async src="https://www.googletagservices.com/tag/js/gpt.js"></script><script src="https://t.gmg.io/ads.release/header.lakana.js?7-19"></script><!-- Tomahawk -->
<link href="//tomahawk.grahamdigital.com/css/thwk-shim.css" rel="stylesheet" />
<script type="text/javascript" src="//tomahawk.grahamdigital.com/css/thwk-topics-standalone-no-gigya.min.js"></script><!-- End Tomahawk -->
<meta content="121026441243349" property="fb:pages" />
<!-- Begin WJXT Chartbeat Header Script--><script type="text/javascript">
     var _sf_async_config = _sf_async_config || {};
     /** CONFIGURATION START **/
    _sf_async_config.uid = 14876; // ACCOUNT NUMBER
    _sf_async_config.domain = 'news4jax.com'; // DOMAIN 
    _sf_async_config.useCanonical = true;
    /** CONFIGURATION END **/
     var _sf_startpt = (new Date()).getTime();
</script><script src="//static.chartbeat.com/js/chartbeat_mab.js"></script><!-- End WJXT Chartbeat Header Script-->
<!-- End header scripts -->

<!-- Begin google analytics -->
        
<!-- End google analytics -->

        <script src='            https://www.news4jax.com/gmg-base-theme/js/main-header.js?minifierType=js&languageId=en_US&b=6110&t=1520163216000'></script>
    
<!-- Nativo Integration Start -->
            <script type="text/javascript" src="//s.ntv.io/serve/load.js"></script>
    <!-- Nativo Integration End -->
</head>

<body data-station="wjxt" data-layout="Story" class="skin-jax controls-visible signed-out public-page organization-site has-large-logo no-subnav">
<!-- Google Tag Manager -->
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-PWN3DX"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-PWN3DX');</script>
<!-- End Google Tag Manager -->





















































































































<!-- begin: WRAPPER -->
<div id="wrapper" class="mobile-overflow-fix">

    <!-- begin: HEADER -->
    <header id="header" class="top-container container">

                    <!-- begin: NAV AREA -->


<!-- Logic for applying super navigation -->


    <div class="{{station}}">
        <div data-header></div>
    </div>

<script>
(function( $ ){
    if( $('#subnav-container').length ){
        $('body').removeClass('no-subnav');

        $.fn.ignore = function(sel){
            return this.clone().find(sel||">*").remove().end();
        };
        var currentLayoutName = "$renderLayout.getName($locale)";
        if(currentLayoutName == "Weather") {
            $("div[class='weather-wrap d-inline']").parent().addClass("current");
        } else {
            $("li.dropdown").each(function(){
                if($.trim($(this).children("a").ignore("span").text()) == currentLayoutName) {
                    $(this).addClass("current");
                }
            });
        }
    }
})( jQuery );
</script>
<!-- end: NAV AREA -->




        
    </header>
    <!-- end: HEADER -->

	<div id="main" class="container" data-role="content">

					



















































































































	
		
































































	

	<div id="p_p_id_103_" class="portlet-boundary portlet-boundary_103_  portlet-static portlet-static-end portlet-borderless  " >
		<span id="p_103"></span>

		<div class="portlet-body">



	
	
	
	

		

			
				
				
					
				
			

		

	





			
		</div>
	</div>





	

<div class="gmg-story-layout" id="main-content" role="main">

    <section class="portlet-layout row">
        <div class="portlet-column col-xs-12" id="column-1">
            <div class="portlet-dropzone portlet-column-content" id="layout-column_column-1">



























































	
		
	
	




























































	
		
































































	

	<div id="p_p_id_56_INSTANCE_uXk2iOoNCjCq_" class="portlet-boundary portlet-boundary_56_  portlet-static portlet-static-end portlet-borderless portlet-journal-content " >
		<span id="p_56_INSTANCE_uXk2iOoNCjCq"></span>

		<div class="portlet-body">



	
	
	
	

		




























































	
	
	
	
	

		

		
			
			

				

				<div class="portlet-borderless-container" style="">
					

					


	<div class="portlet-body">



	
		
			
			
				
					





































































































































	

				

				
					
					
						


	
	
		















































































    

    

    <div class="journal-content-article" id="article_10154_32142_160373951_1.0">
        






        














































      































































        


    	






    																																																																						<!-- begin: TOP LOCAL STORIES -->
<div class="portlet-boundary">
    <section class="mod-wrapper ui-small-carousel mod-top-local">
		<div class="fullWidth"></div>
		<div class="mod-header">
			<h3>Top Local Stories</h3>
		</div>
		<div id="carousel-top-local" class="mod-body owl-carousel owl-theme small-carousel">
								                                            		<div class="owl-item">
			<div class="item top-local">
				<a href="/news/police-homeless-man-charged-after-woman-held-captive-in-hotel-room" target='_self' title="Police&#x3a;&#x20;Homeless&#x20;man&#x20;charged&#x20;after&#x20;woman&#x20;held&#x20;captive&#x20;in&#x20;hotel&#x20;room">
					<div class="image-container">
																														<img src="https://media.news4jax.com/photo/2018/03/05/Marshall-on-Red-Carpet-Inn_1520284117810_11749879_ver1.0_160_90.jpg" alt="">
						<span class="image placeholder-16x9" style="background-image: url(https://media.news4jax.com/photo/2018/03/05/Marshall-on-Red-Carpet-Inn_1520284117810_11749879_ver1.0_160_90.jpg);"></span>
													      <small class="copyright"></small>
											</div>
					<article class="">
						<h5>Police: Homeless man charged after woman held captive in hotel room</h5>
					</article>
				</a>
				<a class="carousel-article-category text-uppercase">
					<h6>News</h6>
				</a>
			</div>
		</div>
					                                            		<div class="owl-item">
			<div class="item top-local">
				<a href="/traffic/4-motorcyclist-die-in-36-hours-on-jacksonville-roads" target='_self' title="4&#x20;motorcyclists&#x20;die&#x20;in&#x20;36&#x20;hours&#x20;on&#x20;Jacksonville&#x20;roads">
					<div class="image-container">
																														<img src="https://media.news4jax.com/photo/2018/03/05/Map-4-motorcycle-fatalities_1520279692659_11749746_ver1.0_160_90.jpg" alt="">
						<span class="image placeholder-16x9" style="background-image: url(https://media.news4jax.com/photo/2018/03/05/Map-4-motorcycle-fatalities_1520279692659_11749746_ver1.0_160_90.jpg);"></span>
													      <small class="copyright"></small>
											</div>
					<article class="">
						<h5>4 motorcyclists die in 36 hours on Jacksonville roads</h5>
					</article>
				</a>
				<a class="carousel-article-category text-uppercase">
					<h6>Traffic</h6>
				</a>
			</div>
		</div>
					                                            		<div class="owl-item">
			<div class="item top-local">
				<a href="/news/local/jacksonville/play-group-returns-to-park-week-after-police-say-man-exposed-himself" target='_self' title="Play&#x20;group&#x20;returns&#x20;to&#x20;park&#x20;week&#x20;after&#x20;police&#x20;say&#x20;man&#x20;exposed&#x20;himself">
					<div class="image-container">
																														<img src="https://media.news4jax.com/photo/2018/02/27/alexander-on-park_1519780849610_11724245_ver1.0_160_90.jpg" alt="">
						<span class="image placeholder-16x9" style="background-image: url(https://media.news4jax.com/photo/2018/02/27/alexander-on-park_1519780849610_11724245_ver1.0_160_90.jpg);"></span>
													      <small class="copyright"></small>
											</div>
					<article class="">
						<h5>Play group returns to park week after police say man exposed himself</h5>
					</article>
				</a>
				<a class="carousel-article-category text-uppercase">
					<h6>Jacksonville</h6>
				</a>
			</div>
		</div>
					                                            		<div class="owl-item">
			<div class="item top-local">
				<a href="/news/local/jacksonville/police-close-downtown-jacksonville-street-due-to-suspicious-item" target='_self' title="&#x27;Suspicious&#x20;item&#x27;&#x20;was&#x20;personal&#x20;belonging&#x3b;&#x20;police&#x20;reopen&#x20;downtown&#x20;streets">
					<div class="image-container">
																														<img src="https://media.news4jax.com/photo/2018/03/05/Newnan-Street-suspicious-it_1520269121668_11749075_ver1.0_160_90.jpg" alt="">
						<span class="image placeholder-16x9" style="background-image: url(https://media.news4jax.com/photo/2018/03/05/Newnan-Street-suspicious-it_1520269121668_11749075_ver1.0_160_90.jpg);"></span>
													      <small class="copyright"></small>
											</div>
					<article class="">
						<h5>'Suspicious item' was personal belonging; police reopen downtown streets</h5>
					</article>
				</a>
				<a class="carousel-article-category text-uppercase">
					<h6>Jacksonville</h6>
				</a>
			</div>
		</div>
					                                            		<div class="owl-item">
			<div class="item top-local">
				<a href="/news/florida-teacher-removed-from-class-over-white-nationalist-podcast" target='_self' title="Florida&#x20;teacher&#x20;removed&#x20;from&#x20;class&#x20;over&#x20;white&#x20;nationalist&#x20;podcast">
					<div class="image-container">
																														<img src="https://media.news4jax.com/photo/2018/03/05/volitichcover_1520271116561_11749904_ver1.0_160_90.jpg" alt="">
						<span class="image placeholder-16x9" style="background-image: url(https://media.news4jax.com/photo/2018/03/05/volitichcover_1520271116561_11749904_ver1.0_160_90.jpg);"></span>
													                  <small class="copyright">Citrus Schools/Twitter</small>
											</div>
					<article class="">
						<h5>Florida teacher removed from class over white nationalist podcast</h5>
					</article>
				</a>
				<a class="carousel-article-category text-uppercase">
					<h6>News</h6>
				</a>
			</div>
		</div>
					                                            		<div class="owl-item">
			<div class="item top-local">
				<a href="/news/florida/nassau-county/principal-of-fernandina-beach-high-resigns-over-missing-funds" target='_self' title="Principal&#x20;of&#x20;Fernandina&#x20;Beach&#x20;High&#x20;resigns&#x20;over&#x20;missing&#x20;funds">
					<div class="image-container">
																														<img src="https://media.news4jax.com/photo/2018/03/05/Principal-Spencer-Lodree-on_1520266152430_11747473_ver1.0_160_90.jpg" alt="">
						<span class="image placeholder-16x9" style="background-image: url(https://media.news4jax.com/photo/2018/03/05/Principal-Spencer-Lodree-on_1520266152430_11747473_ver1.0_160_90.jpg);"></span>
													      <small class="copyright"></small>
											</div>
					<article class="">
						<h5>Principal of Fernandina Beach High resigns over missing funds</h5>
					</article>
				</a>
				<a class="carousel-article-category text-uppercase">
					<h6>Nassau County</h6>
				</a>
			</div>
		</div>
					                                            		<div class="owl-item">
			<div class="item top-local">
				<a href="/news/swat-team-called-to-sans-souci-neighborhood" target='_self' title="Man&#x20;in&#x20;protective&#x20;custody&#x20;after&#x20;SWAT&#x20;team&#x20;called&#x20;to&#x20;Sans&#x20;Souci&#x20;neighborhood">
					<div class="image-container">
																														<img src="https://media.news4jax.com/photo/2018/03/05/Sans%20Souci%20Swat_1520252296008.JPG_11746934_ver1.0_160_90.jpg" alt="">
						<span class="image placeholder-16x9" style="background-image: url(https://media.news4jax.com/photo/2018/03/05/Sans%20Souci%20Swat_1520252296008.JPG_11746934_ver1.0_160_90.jpg);"></span>
													      <small class="copyright"></small>
											</div>
					<article class="">
						<h5>Man in protective custody after SWAT team called to Sans Souci neighborhood</h5>
					</article>
				</a>
				<a class="carousel-article-category text-uppercase">
					<h6>News</h6>
				</a>
			</div>
		</div>
					                                            		<div class="owl-item">
			<div class="item top-local">
				<a href="/news/clay-county-sheriffs-office-looking-for-man-in-oakleaf-area" target='_self' title="Clay&#x20;County&#x20;deputies&#x20;looking&#x20;for&#x20;man&#x20;with&#x20;gun&#x20;in&#x20;Oakleaf&#x20;area">
					<div class="image-container">
																														<img src="https://media.news4jax.com/photo/2017/04/17/Clay-County-Sheriff%27s-Offic_1492467394152_9519792_ver1.0_160_90.jpg" alt="">
						<span class="image placeholder-16x9" style="background-image: url(https://media.news4jax.com/photo/2017/04/17/Clay-County-Sheriff%27s-Offic_1492467394152_9519792_ver1.0_160_90.jpg);"></span>
													      <small class="copyright"></small>
											</div>
					<article class="">
						<h5>Clay County deputies looking for man with gun in Oakleaf area</h5>
					</article>
				</a>
				<a class="carousel-article-category text-uppercase">
					<h6>News</h6>
				</a>
			</div>
		</div>
					                                            		<div class="owl-item">
			<div class="item top-local">
				<a href="/news/man-shot-killed-on-new-town-front-porch" target='_self' title="Police&#x20;ID&#x20;man&#x20;shot&#x2c;&#x20;killed&#x20;on&#x20;New&#x20;Town&#x20;front&#x20;porch">
					<div class="image-container">
																														<img src="https://media.news4jax.com/photo/2018/03/04/03-04-18-fatal-shooting-pic_1520182977806_11744634_ver1.0_160_90.jpg" alt="">
						<span class="image placeholder-16x9" style="background-image: url(https://media.news4jax.com/photo/2018/03/04/03-04-18-fatal-shooting-pic_1520182977806_11744634_ver1.0_160_90.jpg);"></span>
													      <small class="copyright"></small>
											</div>
					<article class="">
						<h5>Police ID man shot, killed on New Town front porch</h5>
					</article>
				</a>
				<a class="carousel-article-category text-uppercase">
					<h6>News</h6>
				</a>
			</div>
		</div>
			</div>
	</section>
</div>
<!-- end: TOP LOCAL STORIES -->
											

    </div>

    











    

    

    

	

					
				
			
			
		
	
	



	</div>

				</div>

				
			
		
	


	





			
		</div>
	</div>





	
	




























































	
		
































































	

	<div id="p_p_id_56_INSTANCE_C9gB4mPXoc3N_" class="portlet-boundary portlet-boundary_56_  portlet-static portlet-static-end portlet-borderless portlet-journal-content " >
		<span id="p_56_INSTANCE_C9gB4mPXoc3N"></span>

		<div class="portlet-body">



	
	
	
	

		




























































	
	
	
	
	

		

		
			
			

				

				<div class="portlet-borderless-container" style="">
					

					


	<div class="portlet-body">



	
		
			
			
				
					





































































































































	

				

				
					
					
						


	
	
		















































































    

    

    <div class="journal-content-article" id="article_10154_32142_38404_1.0">
        






        














































      































































        



      
        
          
    
                                                                              
          <!-- Begin: Ad -->
        <section class="mod-wrapper mod-ad    ">
      <div class="mod-body gmg-ad" data-gmgad='{ "unitname" : "/15466288/WJXT/Web/news/florida/clay_county", "mobile_size" : [[320, 50]], "tablet_size" : [[728, 90]], "desktop_size" : [[728, 90], [1000, 300],[1000, 40], [970, 250], [970, 90]], "position" : "LEADER_BOARD" }'></div>
    </section>
      <!-- End: Ad -->



    </div>

    











    

    

    

	

					
				
			
			
		
	
	



	</div>

				</div>

				
			
		
	


	





			
		</div>
	</div>





	
	
</div>
        </div>
    </section>

    <section class="content-container portlet-layout row">

        <div id="article-filter-wrap" class="portlet-column col-sm-7 col-md-8 wrap-mods" id="column-2">
            <div class="portlet-dropzone portlet-column-content" id="layout-column_column-2">



























































	
		
































































	

	<div id="p_p_id_101_" class="portlet-boundary portlet-boundary_101_  portlet-static portlet-static-end portlet-borderless portlet-asset-publisher " >
		<span id="p_101"></span>

		<div class="portlet-body">



	
	
	
	

		




























































	
	
	
	
	

		

		
			
			

				

				<div class="portlet-borderless-container" style="">
					

					


	<div class="portlet-body">



	
		
			
			
				
					





































































































































	

				

				
					
					
						


	
	
		






































































	<div>
		








































































<div class="asset-full-content default-asset-publisher no-title">
	
		







































































	

	

	

	<div class="asset-content">
		

		

		





































































































	<div class="journal-content-article">
		






        














































      































































        

  
        
          








        




    






<!-- render audio/video/livestream story -->
<!-- render end -->

































<!-- begin: STORY -->
<section class="mod-wrapper mod-story" style="width:100%;">
    <header class="mod-header">
                    
                    <div class="category news"><a href="#">Clay County</a></div>
                <h1 class="headline">Charges against former pastor dropped</h1>
        <h2 class="sub-headline">Police say he slammed wife's head into kitchen counter</h2>
        <div class="author">                                                                                                                           By <a href = 'https://www.news4jax.com/author/news4jax.comstaff'>News4Jax.com Staff</a>
   </div>
                         <time class="posted updated" datetime="2017-10-30">Posted: 2:13 PM, October 30, 2017</time>
                    <time class="updated" datetime="2018-03-05">Updated: 3:47 PM, March 05, 2018</time>
            <!-- Viafoura Share Bar Widget -->
    <div class="gmg-vf viafoura">
        <div class="vf-widget vf-share-bar-square" data-widget="sharebar" data-button-view="false" data-show-labels="false" data-show-counters="false" data-show-total="false">
        </div>
        <div class="viafoura counts">
            <span class="vf-counter vf-widget" data-widget="counter"></span>
            <span class="vf-widget vf-quote" data-widget="sharetotal" data-realtime=true></span>
        </div>
    </div>
 
     </header>
    <div class="mod-body">
                                                                                <figure class="wrapper-media photo">
            <span class="crop-photo" style="background-image: url('https://media.news4jax.com/photo/2017/10/30/James-Weldon_1509386565996_10883216_ver1.0_640_360.jpg');">
                <img src="https://media.news4jax.com/theme/images/placeholder_16x9_wjxt.png" alt="Headline Goes Here"/>
            </span>
                  <small class="copyright"></small>
                            <figcaption>
                    <p>James Welson, 55, booking photo</p>
                </figcaption>
                    </figure>
                                <div id="story-relate-headline" style="display:none">
             
        </div>
                <div class="story-content" itemprop="articleBody">
            
 
                        <!-- render embed module start-->
        <!-- render embed module end -->
  
 
                                          
  




  
      
      
      
      
      

             <p><strong>FLEMING ISLAND, Fla.</strong> - Domestic violence&nbsp;charges against&nbsp;former Presbyterian pastor have been dropped.
                     <p>James Weldon, 55, was arrested Oct. 29. According to the police report, he yelled at wife before spitting in her face,&nbsp;grabbing her by her jaw and slamming her head into the kitchen counter, police said.&nbsp;
                                  <p>Authorities said Weldon&rsquo;s wife grabbed a kitchen tong to defend herself, then threw brownies at him before escaping their home on Trailing Pines Way in Fleming Island.
                     <p>Charges were dropped the following month.
                     <p>Weldon was forced to resign as pastor at the Fleming Island Presbyterian Church, which closed last year amid investigations into the church&rsquo;s financial problems.<br />&nbsp;
                              <p class="copy">Copyright 2017 by WJXT News4Jax - All rights reserved.</p>
  
        </div>
                            <div class="emailWidget">
  <a class="emailLink" target="_blank" href="https://cb.sailthru.com/join/54w/signup">
    <div class="emailMessage"><p>Get email alerts for local stories and events around the world.</p></div>
    <div class="emailButton">Sign Up</div>
  </a>
 </div>

   </div>
</section>
<!-- end: STORY -->















	</div>
	
	



		

		

		

		

		

		
	</div>

	
		<div class="asset-metadata">
			


		</div>
	
</div>


	
	



	</div>

	









































































	

					
				
			
			
		
	
	



	</div>

				</div>

				
			
		
	


	





			
		</div>
	</div>





	
	




























































	
		
































































	

	<div id="p_p_id_56_INSTANCE_WK3du8AxnQ6L_" class="portlet-boundary portlet-boundary_56_  portlet-static portlet-static-end portlet-borderless portlet-journal-content " >
		<span id="p_56_INSTANCE_WK3du8AxnQ6L"></span>

		<div class="portlet-body">



	
	
	
	

		




























































	
	
	
	
	

		

		
			
			

				

				<div class="portlet-borderless-container" style="">
					

					


	<div class="portlet-body">



	
		
			
			
				
					





































































































































	

				

				
					
					
						


	
	
		















































































    

    

    <div class="journal-content-article" id="article_10154_32142_615975035_1.0">
        <!-- Klangoo Entity Tags Widget WJXT -->
<div data-widget-id="ent_209-1"></div>
    </div>

    











    

    

    

	

					
				
			
			
		
	
	



	</div>

				</div>

				
			
		
	


	





			
		</div>
	</div>





	
	




























































	
		
































































	

	<div id="p_p_id_56_INSTANCE_Bg3cc3ddhDII_" class="portlet-boundary portlet-boundary_56_  portlet-static portlet-static-end portlet-borderless portlet-journal-content " >
		<span id="p_56_INSTANCE_Bg3cc3ddhDII"></span>

		<div class="portlet-body">



	
	
	
	

		




























































	
	
	
	
	

		

		
			
			

				

				<div class="portlet-borderless-container" style="">
					

					


	<div class="portlet-body">



	
		
			
			
				
					





































































































































	

				

				
					
					
						


	
	
		















































































    

    

    <div class="journal-content-article" id="article_10154_32142_M-SPONSORED--COMMENTS_1.0">
        






        














































      































































        <!-- comment block -->
	 <section class="mod-wrapper mod-comments">
  <div class="mod-body">
  <div id="gmg-vf-comments" class="viafoura">
            <div id="gmg-vf-page-comments" class="vf-comments vf-widget" data-widget="comments"></div>
   </div>
  </div>
 </section>

    </div>

    











    

    

    

	

					
				
			
			
		
	
	



	</div>

				</div>

				
			
		
	


	





			
		</div>
	</div>





	
	




























































	
		
































































	

	<div id="p_p_id_56_INSTANCE_dX3zuuXxTUU8_" class="portlet-boundary portlet-boundary_56_  portlet-static portlet-static-end portlet-borderless portlet-journal-content " >
		<span id="p_56_INSTANCE_dX3zuuXxTUU8"></span>

		<div class="portlet-body">



	
	
	
	

		




























































	
	
	
	
	

		

		
			
			

				

				<div class="portlet-borderless-container" style="">
					

					


	<div class="portlet-body">



	
		
			
			
				
					





































































































































	

				

				
					
					
						


	
	
		















































































    

    

    <div class="journal-content-article" id="article_10154_32142_M-SPONSORED--YOU-MIGHT-ALSO-LIKE_1.0">
        






        














































      































































        

<div id="outbrain-placeholder"></div>
<script type="text/javascript">
    if(EP.Util.isMobile()) {
        $("#outbrain-placeholder").replaceWith('<div class="OUTBRAIN" data-src="https://www.news4jax.com/news/florida/clay-county/former-pastor-charged-with-domestic-battery" data-widget-id="MB_2" data-ob-template="news4jax.com" ></div>');
    } else {
        $("#outbrain-placeholder").replaceWith(
            '<div class="OUTBRAIN" data-src="https://www.news4jax.com/news/florida/clay-county/former-pastor-charged-with-domestic-battery" data-widget-id="AR_3" data-ob-template="news4jax.com" ></div>' +
            '<div class="OUTBRAIN" data-src="https://www.news4jax.com/news/florida/clay-county/former-pastor-charged-with-domestic-battery" data-widget-id="AR_4" data-ob-template="news4jax.com" ></div>'
        );
    }
</script>
<script type="text/javascript" async="async" src="//widgets.outbrain.com/outbrain.js"></script>


    </div>

    











    

    

    

	

					
				
			
			
		
	
	



	</div>

				</div>

				
			
		
	


	





			
		</div>
	</div>





	
	




























































	
		
































































	

	<div id="p_p_id_56_INSTANCE_GC1Hotk0Chyr_" class="portlet-boundary portlet-boundary_56_  portlet-static portlet-static-end portlet-borderless portlet-journal-content " >
		<span id="p_56_INSTANCE_GC1Hotk0Chyr"></span>

		<div class="portlet-body">



	
	
	
	

		




























































	
	
	
	
	

		

		
			
			

				

				<div class="portlet-borderless-container" style="">
					

					


	<div class="portlet-body">



	
		
			
			
				
					





































































































































	

				

				
					
					
						


	
	
		















































































    

    

    <div class="journal-content-article" id="article_10154_32142_521638464_1.0">
        <!-- Klangoo In-Text Entities Linking WJXT --><div data-widget-id="itent_209-1"></div>
    </div>

    











    

    

    

	

					
				
			
			
		
	
	



	</div>

				</div>

				
			
		
	


	





			
		</div>
	</div>





	
	




























































	
		
































































	

	<div id="p_p_id_56_INSTANCE_hdUeW5qGcq0p_" class="portlet-boundary portlet-boundary_56_  portlet-static portlet-static-end portlet-borderless portlet-journal-content " >
		<span id="p_56_INSTANCE_hdUeW5qGcq0p"></span>

		<div class="portlet-body">



	
	
	
	

		




























































	
	
	
	
	

		

		
			
			

				

				<div class="portlet-borderless-container" style="">
					

					


	<div class="portlet-body">



	
		
			
			
				
					





































































































































	

				

				
					
					
						


	
	
		















































































    

    

    <div class="journal-content-article" id="article_10154_32142_500437688_1.0">
        <!-- WJXT Klangoo Magnet Recom Videos In-Player Plugin -->
<div data-widget-id="recom_209-1"></div>
    </div>

    











    

    

    

	

					
				
			
			
		
	
	



	</div>

				</div>

				
			
		
	


	





			
		</div>
	</div>





	
	
</div>
        </div>

        <div id="sidebar-wrap" class="portlet-column col-sm-5 col-md-4 wrap-mods home" id="column-3">
            <div class="portlet-dropzone portlet-column-content" id="layout-column_column-3">



























































	
		
































































	

	<div id="p_p_id_56_INSTANCE_aETvx2rzZMgz_" class="portlet-boundary portlet-boundary_56_  portlet-static portlet-static-end portlet-borderless portlet-journal-content " >
		<span id="p_56_INSTANCE_aETvx2rzZMgz"></span>

		<div class="portlet-body">



	
	
	
	

		




























































	
	
	
	
	

		

		
			
			

				

				<div class="portlet-borderless-container" style="">
					

					


	<div class="portlet-body">



	
		
			
			
				
					





































































































































	

				

				
					
					
						


	
	
		















































































    

    

    <div class="journal-content-article" id="article_10154_32142_38496_1.0">
        






        














































      































































        



      
        
          
    
                                                                              
          <!-- Begin: Ad -->
        <section class="mod-wrapper mod-ad                                          
          ui-large-screen ui-larger-screen ui-largest-screen
      ">
      <div class="mod-body gmg-ad" data-gmgad='{ "unitname" : "/15466288/WJXT/Web/news/florida/clay_county", "mobile_size" : [[300, 250]], "tablet_size" : [[300, 250]], "desktop_size" : [[300, 250],[300,600]], "position" : "RIGHT1" }'></div>
    </section>
      <!-- End: Ad -->



    </div>

    











    

    

    

	

					
				
			
			
		
	
	



	</div>

				</div>

				
			
		
	


	





			
		</div>
	</div>





	
	




























































	
		
































































	

	<div id="p_p_id_56_INSTANCE_E91yuFABv3sh_" class="portlet-boundary portlet-boundary_56_  portlet-static portlet-static-end portlet-borderless portlet-journal-content " >
		<span id="p_56_INSTANCE_E91yuFABv3sh"></span>

		<div class="portlet-body">



	
	
	
	

		




























































	
	
	
	
	

		

		
			
			

				

				<div class="portlet-borderless-container" style="">
					

					


	<div class="portlet-body">



	
		
			
			
				
					





































































































































	

				

				
					
					
						


	
	
		















































































    

    

    <div class="journal-content-article" id="article_10154_32142_M-SPONSORED-WJXT-TOP-STORIES-NEW_1.1">
        






        














































      































































        














    <!-- begin: HEADLINES -->
    
                            				<section class="mod-wrapper mod-filtered-list mod-list-media   ">
					
                <header class="mod-header">
         <h3>News Headlines</h3>
       </header>
            
                                               
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                            
                                                                                                                                                                                                <div class="mod-body" ajaxURL='/web/wjxt/refresh-article/107394/M-SPONSORED-WJXT-TOP-STORIES-NEW/HEADLINE_LIST_PAGINATION?restulsPerPage=5&pageNum=' pageNum='1' resultsPerPage='5'>
                    <ul class="list media mixed">
                                                                                                                  
                                                                                                                            
    
                
            
                                                                                                <li>
        					<a href='/news/police-homeless-man-charged-after-woman-held-captive-in-hotel-room' target='_self'>
					<img class="f-left thumb" src="https://media.news4jax.com/photo/2018/03/05/Marshall-on-Red-Carpet-Inn_1520284117810_11749879_ver1.0_160_90.jpg" alt='Police&#x3a;&#x20;Homeless&#x20;man&#x20;charged&#x20;after&#x20;woman&#x20;held&#x20;captive&#x20;in&#x20;hotel&#x20;room'>
											      <small class="copyright"></small>
										<h4>Police: Homeless man charged after woman held captive in hotel room</h4>
				</a>
			        </li>
    
                                                                                                      
                                                                                                                            
    
                
            
                                                                                                <li>
        					<a href='/traffic/4-motorcyclist-die-in-36-hours-on-jacksonville-roads' target='_self'>
					<img class="f-left thumb" src="https://media.news4jax.com/photo/2018/03/05/Map-4-motorcycle-fatalities_1520279692659_11749746_ver1.0_160_90.jpg" alt='4&#x20;motorcyclists&#x20;die&#x20;in&#x20;36&#x20;hours&#x20;on&#x20;Jacksonville&#x20;roads'>
											      <small class="copyright"></small>
										<h4>4 motorcyclists die in 36 hours on Jacksonville roads</h4>
				</a>
			        </li>
    
                                                                                                      
                                                                                                                            
    
                
            
                                                                                                <li>
        					<a href='/news/local/jacksonville/play-group-returns-to-park-week-after-police-say-man-exposed-himself' target='_self'>
					<img class="f-left thumb" src="https://media.news4jax.com/photo/2018/02/27/alexander-on-park_1519780849610_11724245_ver1.0_160_90.jpg" alt='Play&#x20;group&#x20;returns&#x20;to&#x20;park&#x20;week&#x20;after&#x20;police&#x20;say&#x20;man&#x20;exposed&#x20;himself'>
											      <small class="copyright"></small>
										<h4>Play group returns to park week after police say man exposed himself</h4>
				</a>
			        </li>
    
                                                                                                      
                                                                                                                            
    
                
            
                                                                                                <li>
        					<a href='/news/local/jacksonville/police-close-downtown-jacksonville-street-due-to-suspicious-item' target='_self'>
					<img class="f-left thumb" src="https://media.news4jax.com/photo/2018/03/05/Newnan-Street-suspicious-it_1520269121668_11749075_ver1.0_160_90.jpg" alt='&#x27;Suspicious&#x20;item&#x27;&#x20;was&#x20;personal&#x20;belonging&#x3b;&#x20;police&#x20;reopen&#x20;downtown&#x20;streets'>
											      <small class="copyright"></small>
										<h4>'Suspicious item' was personal belonging; police reopen downtown streets</h4>
				</a>
			        </li>
    
                                                                                                      
                                                                                                                            
    
                
            
                                                                                                <li>
        					<a href='/news/florida-teacher-removed-from-class-over-white-nationalist-podcast' target='_self'>
					<img class="f-left thumb" src="https://media.news4jax.com/photo/2018/03/05/volitichcover_1520271116561_11749904_ver1.0_160_90.jpg" alt='Florida&#x20;teacher&#x20;removed&#x20;from&#x20;class&#x20;over&#x20;white&#x20;nationalist&#x20;podcast'>
											                  <small class="copyright">Citrus Schools/Twitter</small>
										<h4>Florida teacher removed from class over white nationalist podcast</h4>
				</a>
			        </li>
    
                                                                                                                                                                                </ul>
                </div>
                
                         				</section>
                        
 <!-- end: HEADLINES -->


    </div>

    











    

    

    

	

					
				
			
			
		
	
	



	</div>

				</div>

				
			
		
	


	





			
		</div>
	</div>





	
	




























































	
		
































































	

	<div id="p_p_id_56_INSTANCE_cE8pD6YshYD1_" class="portlet-boundary portlet-boundary_56_  portlet-static portlet-static-end portlet-borderless portlet-journal-content " >
		<span id="p_56_INSTANCE_cE8pD6YshYD1"></span>

		<div class="portlet-body">



	
	
	
	

		




























































	
	
	
	
	

		

		
			
			

				

				<div class="portlet-borderless-container" style="">
					

					


	<div class="portlet-body">



	
		
			
			
				
					





































































































































	

				

				
					
					
						


	
	
		















































































    

    

    <div class="journal-content-article" id="article_10154_32142_122375338_1.0">
        






        














































      































































        



      
        
          
    
                                                                              
          <!-- Begin: Ad -->
        <section class="mod-wrapper mod-ad                                          
          ui-large-screen ui-larger-screen ui-largest-screen
      ">
      <div class="mod-body gmg-ad" data-gmgad='{ "unitname" : "/15466288/Promos/WJXT/news/florida/clay_county", "mobile_size" : [[300, 250]], "tablet_size" : [[300, 250]], "desktop_size" : [[300, 250],[300,600]], "position" : "RIGHT2" }'></div>
    </section>
      <!-- End: Ad -->



    </div>

    











    

    

    

	

					
				
			
			
		
	
	



	</div>

				</div>

				
			
		
	


	





			
		</div>
	</div>





	
	




























































	
		
































































	

	<div id="p_p_id_56_INSTANCE_PBELU96Vgkah_" class="portlet-boundary portlet-boundary_56_  portlet-static portlet-static-end portlet-borderless portlet-journal-content " >
		<span id="p_56_INSTANCE_PBELU96Vgkah"></span>

		<div class="portlet-body">



	
	
	
	

		




























































	
	
	
	
	

		

		
			
			

				

				<div class="portlet-borderless-container" style="">
					

					


	<div class="portlet-body">



	
		
			
			
				
					





































































































































	

				

				
					
					
						


	
	
		















































































    

    

    <div class="journal-content-article" id="article_10154_32142_386533884_1.0">
        






        














































      































































        














    <!-- begin: HEADLINES -->
    
                            				<section class="mod-wrapper mod-list-headlines                                         
          ui-large-screen ui-larger-screen ui-largest-screen
      ">
					
                <header class="mod-header">
         <h3>U.S. and World News</h3>
       </header>
            
                                               
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                
                                                                                                                                                                                <div class="mod-body" ajaxURL='/web/wjxt/refresh-article/107394/386533884/HEADLINE_LIST_PAGINATION?restulsPerPage=4&pageNum=' pageNum='1' resultsPerPage='4'>
                    <ul class="list">
                                                    																																						    
        
            
        
                                                        <li>
            <a href='https://www.clickondetroit.com/news/police-alt-right-supporter-of-richard-spencer-charged-after-pointing-gun-a-protesters?utm_source=gmg&utm_campaign=links' target='_self'>
                WDIV: Richard Spencer supporter charged after pointing gun at protesters 
            </a>
        </li>
    																				
																																															    
        
            
        
                                                        <li>
            <a href='/news/national/parents-of-school-shooting-victims-call-on-florida-legislature-to-make-schools-safe' target='_self'>
                Parents of school shooting victims call on Florida legislature to make&hellip; 
            </a>
        </li>
    																				
																																															    
        
            
        
                                                        <li>
            <a href='/news/national/tennessee-school-removes-confederate-flag-lynching-murals' target='_self'>
                Tennessee school removes Confederate flag, lynching murals 
            </a>
        </li>
    																				
																																															    
        
            
        
                                                        <li>
            <a href='/news/politics/wsj-cohen-complained-about-lack-of-reimbursement-for-porn-star-payment' target='_self'>
                WSJ: Cohen complained about lack of reimbursement for porn star payment 
            </a>
        </li>
    																				
																								                                            </ul>
                </div>
                
                         				</section>
                        
 <!-- end: HEADLINES -->


    </div>

    











    

    

    

	

					
				
			
			
		
	
	



	</div>

				</div>

				
			
		
	


	





			
		</div>
	</div>





	
	




























































	
		
































































	

	<div id="p_p_id_56_INSTANCE_DEH96AJdUkfL_" class="portlet-boundary portlet-boundary_56_  portlet-static portlet-static-end portlet-borderless portlet-journal-content " >
		<span id="p_56_INSTANCE_DEH96AJdUkfL"></span>

		<div class="portlet-body">



	
	
	
	

		




























































	
	
	
	
	

		

		
			
			

				

				<div class="portlet-borderless-container" style="">
					

					


	<div class="portlet-body">



	
		
			
			
				
					





































































































































	

				

				
					
					
						


	
	
		















































































    

    

    <div class="journal-content-article" id="article_10154_32142_124073654_1.1">
        






        














































      































































        



      
        
          
    
                                                                              
          <!-- Begin: Ad -->
        <section class="mod-wrapper mod-ad                                          
          ui-large-screen ui-larger-screen ui-largest-screen
      ">
      <div class="mod-body gmg-ad" data-gmgad='{ "unitname" : "/15466288/WJXT/Web/news/florida/clay_county", "mobile_size" : [[300, 250]], "tablet_size" : [[300, 250]], "desktop_size" : [[300, 250],[300,600]], "position" : "RIGHT1" }'></div>
    </section>
      <!-- End: Ad -->



    </div>

    











    

    

    

	

					
				
			
			
		
	
	



	</div>

				</div>

				
			
		
	


	





			
		</div>
	</div>





	
	




























































	
		
































































	

	<div id="p_p_id_56_INSTANCE_0V4LwGcTblj2_" class="portlet-boundary portlet-boundary_56_  portlet-static portlet-static-end portlet-borderless portlet-journal-content " >
		<span id="p_56_INSTANCE_0V4LwGcTblj2"></span>

		<div class="portlet-body">



	
	
	
	

		




























































	
	
	
	
	

		

		
			
			

				

				<div class="portlet-borderless-container" style="">
					

					


	<div class="portlet-body">



	
		
			
			
				
					





































































































































	

				

				
					
					
						


	
	
		















































































    

    

    <div class="journal-content-article" id="article_10154_32142_498441505_1.0">
        






        














































      































































        




  <div id='m498441505' class='mod '>
    <div class='module generic iframe'>
      <div class="module-wrapper">
        <div class="module-bg  ui-tabs ui-widget ui-widget-content ui-corner-all ">
            <div class='corners'>
    <div class='tl'></div>
    <div class='tr'></div>
    <div class='bl'></div>
    <div class='br'></div>
  </div>
                                	
		                                
      	
			
	
    <div class='content'>    							<div align="center">
<table border="0" cellpadding="8" cellspacing="8">
	<tbody>
		<tr>
			<td bgcolor="#eaeaea">
				<p><img align="left" alt="News4Jax logo" hspace="2" src="https://media.news4jax.com/photo/2017/01/07/News4Jax-transparent-top-le_8767210_ver1.0.png" width="120" /><span style="font-family: inherit;">&nbsp;is here 24/7 to make sure you don&#39;t miss a thing that happens in our community. And you don&#39;t have to visit the web or our apps to stay up to date.</span></p><a href="http://link.news4jax.com/join/54w/signup" style="font-size: 12px; font-family: Helvetica, Arial, sans-serif; color: rgb(226, 57, 33); outline: 0px; cursor: pointer;"><img align="right" hspace="8" src="https://media.news4jax.com/photo/2017/01/07/email-icon_8765833_ver1.0.png" style="font-size: 12px;" vspace="8" width="20%" /></a><p>Get news summaries in your inbox when you most want them. Add alerts for breaking news or severe weather, daily forecasts or entertainment headlines.</p><p style="text-align: center;"><em><a href="http://link.news4jax.com/join/54w/signup">Sign up for eNewsletters today. It&#39;s&#160;free.</a></em></p></td>
		</tr>
	</tbody>
</table>
</div><p></p>
			    </div>

                  </div>
      </div>
    </div>
  </div>
                        

    </div>

    











    

    

    

	

					
				
			
			
		
	
	



	</div>

				</div>

				
			
		
	


	





			
		</div>
	</div>





	
	




























































	
		
































































	

	<div id="p_p_id_56_INSTANCE_tndpwT4WljH1_" class="portlet-boundary portlet-boundary_56_  portlet-static portlet-static-end portlet-borderless portlet-journal-content " >
		<span id="p_56_INSTANCE_tndpwT4WljH1"></span>

		<div class="portlet-body">



	
	
	
	

		




























































	
	
	
	
	

		

		
			
			

				

				<div class="portlet-borderless-container" style="">
					

					


	<div class="portlet-body">



	
		
			
			
				
					





































































































































	

				

				
					
					
						


	
	
		















































































    

    

    <div class="journal-content-article" id="article_10154_32142_386530709_1.1">
        






        














































      































































        














    <!-- begin: HEADLINES -->
    
                            				<section class="mod-wrapper mod-filtered-list mod-list-media                                         
          ui-large-screen ui-larger-screen ui-largest-screen
      ">
					
                <header class="mod-header">
         <h3>Latest Videos</h3>
       </header>
            
                                               
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                        
                                                                                                                                                                                                <div class="mod-body" ajaxURL='/web/wjxt/refresh-article/107394/386530709/HEADLINE_LIST_PAGINATION?restulsPerPage=2&pageNum=' pageNum='1' resultsPerPage='2'>
                    <ul class="list media mixed">
                                                                                                                  
                                                                                                                            
    
                
            
                                                                                                <li>
        					<a href='/weather/jacksonville-weather-forecast-03052018' target='_self'>
					<img class="f-left thumb" src="https://media.news4jax.com/photo/2018/03/05/1_1520277399671_11749928_ver1.0_160_90.png" alt='Clear&#x2c;&#x20;chilly&#x20;evening'>
											      <small class="copyright"></small>
										<h4>Clear, chilly evening</h4>
				</a>
			        </li>
    
                                                                                                      
                                                                                                                            
    
                
            
                                                                                                <li>
        					<a href='/education/whats-wanted-in-the-next-dcps-superintendent' target='_self'>
					<img class="f-left thumb" src="https://media.news4jax.com/photo/2016/09/23/Duval-County-School-Board-m_1474644565749_8035799_ver1.0_160_90.jpg" alt='What&#x27;s&#x20;wanted&#x20;in&#x20;next&#x20;Duval&#x20;County&#x20;school&#x20;superintendent'>
											      <small class="copyright"></small>
										<h4>What's wanted in next Duval County school superintendent</h4>
				</a>
			        </li>
    
                                                                                                                                                                                </ul>
                </div>
                
                         				</section>
                        
 <!-- end: HEADLINES -->


    </div>

    











    

    

    

	

					
				
			
			
		
	
	



	</div>

				</div>

				
			
		
	


	





			
		</div>
	</div>





	
	




























































	
		
































































	

	<div id="p_p_id_56_INSTANCE_cQqGVw90EyVU_" class="portlet-boundary portlet-boundary_56_  portlet-static portlet-static-end portlet-borderless portlet-journal-content " >
		<span id="p_56_INSTANCE_cQqGVw90EyVU"></span>

		<div class="portlet-body">



	
	
	
	

		




























































	
	
	
	
	

		

		
			
			

				

				<div class="portlet-borderless-container" style="">
					

					


	<div class="portlet-body">



	
		
			
			
				
					





































































































































	

				

				
					
					
						


	
	
		















































































    

    

    <div class="journal-content-article" id="article_10154_32142_124073679_1.0">
        






        














































      































































        



      
        
          
    
                                                                              
            <!-- Begin: Ad -->
        <div class="sticky-wrapper">
      <section class="mod-wrapper mod-ad ad-sticky                                         
          ui-large-screen ui-larger-screen ui-largest-screen
      ">
      <div class="mod-body gmg-ad" data-gmgad='{ "unitname" : "/15466288/WJXT/Web/news/florida/clay_county", "mobile_size" : [[300, 250]], "tablet_size" : [[300, 250]], "desktop_size" : [[300, 250],[300,600]], "position" : "RIGHT1" }'></div>
    </section>
      </div>
      <!-- End: Ad -->



    </div>

    











    

    

    

	

					
				
			
			
		
	
	



	</div>

				</div>

				
			
		
	


	





			
		</div>
	</div>





	
	
</div>
        </div>

    </section>

    <section class="portlet-layout row">
        <div class="portlet-column col-xs-12" id="column-4">
            <div class="portlet-dropzone empty portlet-column-content" id="layout-column_column-4"></div>
        </div>
    </section>
</div>




	







<form action="#" id="hrefFm" method="post" name="hrefFm">
	<span></span>
</form>
			</div>

  <!-- begin: FOOTER -->
  <footer id="footer" class="bottom-container" role="contentinfo">
    <!-- Begin footer scripts includes -->
            
        <span class="hidden site_friendly_url">https://www.news4jax.com</span>
            <div data-footer></div>
    <!-- End footer scripts includes -->
  </footer>
  <!-- end: FOOTER -->

</div>
<!-- end: WRAPPER -->














































































































<!-- omniture scripts -->


































































	









	





	

	



	


	



	



	

	



	


	



	
















<script type="text/javascript">
// <![CDATA[

	Liferay.Util.addInputFocus();

	
		Liferay.Portlet.runtimePortletIds = ['103'];
	

	

	
		
		

			

			
		
	

// ]]>
</script>








	










<script type="text/javascript">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</script>











    <script src="https://www.news4jax.com/gmg-base-theme/js/main.js?minifierType=js&amp;languageId=en_US&amp;b=6110&amp;t=1520163216000" type="text/javascript"></script>





	

	

	<script type="text/javascript">
		// <![CDATA[
			(function () {
var s = document.createElement("style");
s.innerHTML = ".glyphicon-film:before {  content: '\\e072'; }"
document.body.appendChild(s);
})();

			
		// ]]>
	</script>









  
<!-- Begin footer scripts includes -->
<script src="https://t.gmg.io/ads.release/footer.js?3-20" async charset="utf-8"></script>
<!-- End footer scripts includes -->

</body>
</html>


